Jump to content
Larry Ullman's Book Forums

mtester

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mtester

  • Rank
    Newbie
  1. I believe you are misunderstanding how permissions are used in *nix systems. Setting the permission 6 (or rw) is not good in general on a directory. You want 5 or 7. So 755 or 775 or 777 are the most common ones. Why? This is taken from Wikipedia. There are numerous other sources available. Something else you may want to look at is the Umask being set. That controls the default permissions of new directories/files when they are created. This is usually set in ~/.bashrc as umask 022 # default files permissions are 644 and for directories, 755 or umask 027 # default files pe
  2. Sorry, this year has been crazy so far. I've been dropping the ball too. GoDaddy has this format: "home" path: /var/chroot/home/content/12/123456789/ webroot is then: /var/chroot/home/content/12/123456789/html Multiple domain names are like this: ~/html/domainone ~/html/domaintwo ~/html/domainthree My purpose is making a customer review site. The customer doesn't have their own hosting yet, so I'm just loading their site up on one of my domains, such as: ~/html/domainfive/customername/ <-- this should be what Yii thinks is the webroot. It's not a huge issue.
  3. If it wasn't clear above, I modified my dev server to be like my real server. GoDaddy: /home/user/html/domainname/sitename/index.php Dev: /var/www/domainname/sitename/index.php I would have hoped this would result in identical environments for this, but GoDaddy is doing something different. I changed my urlmanager rules back to normal on my dev server: 'urlManager'=>array( 'urlFormat'=>'path', 'rules'=>array( '/' => 'site/index', 'home' => 'site/index', '<view:(about)>' => 'site/page',
  4. No, not yet. Although to be honest, with the holidays, I haven't done much of anything the past few weeks. Right now, I'm playing with my development environment, setting it up to match GoDaddy's setup more so I can keep things in sync better once I find the answer. I've tried playing with urlManager rule settings, for example, changing: 'view:(about)>' => 'site/page', '<controller:\w+>/<id: \d+>' => '<controller>/view', to: 'view:(about)>' => 'sitename/site/page', '<controller:\w+>/<id: \d+>' => 'sitename/<controller>/view',
  5. Additional notes: With UrlManager turned off, links look correct, i.e.: domain.com/sitename/index.php?r=site/page&view=about With UrlManager turned on to the default settings, I get the above errors. Default Settings: 'urlManager'=>array( 'urlFormat'=>'path', 'rules'=>array( '<controller:\w+>/<id:\d+>'=>'<controller>/view', '<controller:\w+>/<action:\w+>/<id:\d+>'=>'<controller>/<action>',
  6. Hi, I have a bit of an odd (for me) problem. I originally created a yii site on a production server to play around with, and it worked fine. (1.1.13) In earnest, I created a site on my local server recently, which is working fine. (1.1.14) I removed the old installation from my production server, installed 1.1.14, and zipped/uploaded my local yii site. On my local site, the path is /var/www/<sitename>/index.php On my production server (GoDaddy), the path is ~/html/<domainname>/<sitename>/index.php Now links are showing up on the production site as: do
×
×
  • Create New...