Jump to content
Larry Ullman's Book Forums

jack-the-lad

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About jack-the-lad

  • Rank
    Newbie
  1. Hi Larry After running the example provided on page 460 section 11 I get the following error: Warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\html\xperiment\raw-js\modern-js\ch-11\resources\contact.php on line 2 Here is my Code: <?php # Script 13.3 - login.php mail('jack.ui.maynard@gmail.com', 'Contact form Submission', $body, $from); ?>The message has been sent. And here is my php.ini file : smtp section [mail function] ; For Win32 only. ; http://php.net/smtp SMTP = localhost http://php.net/smtp-port smtp_port = 25 ; For Win32 only. ; http://php.net/sendmail-from sendmail_from = you@yourdomain ; For Unix only. You may supply arguments as well (default: "sendmail -t -i"). ; http://php.net/sendmail-path ;sendmail_path = ; Force the addition of the specified parameters to be passed as extra parameters ; to the sendmail binary. These parameters will always replace the value of ; the 5th parameter to mail(), even in safe mode. ;mail.force_extra_parameters = ; Add X-PHP-Originating-Script: that will include uid of the script followed by the filename mail.add_x_header = On ; Log all mail() calls including the full path of the script, line #, to address and headers ;mail.log = CAn you please advise what I have to do. Thank you.
×
×
  • Create New...