Jump to content
Larry Ullman's Book Forums

sandy

Members
  • Content Count

    6
  • Joined

  • Last visited

  • Days Won

    1

sandy last won the day on April 26 2014

sandy had the most liked content!

Community Reputation

2 Neutral

About sandy

  • Rank
    Newbie
  1. Yes, I don't think it a huge deal. I'm working on AWS and it's not a huge issue as far as I can tell. I have not tried anything other then 777 yet, if I do get some time I'll try other setting but it may be pointless on the VPC Sandy
  2. Started looking at my directory of session files and it seems like they are never getting garbage collected. I started looking around in the Yii codebase and in v1.1.13 they had what looked like a default setting of 1% In v1.1.14 it seems that code has been removed to allow the default of php.ini to be the default. When I looked at the php.ini in the Amazon AWS (AMI Linux) it was something like this - session.gc_probability = 1 and session.gc_divisor = 1000 Which gives a .1% chance by default. So the default in 1.1.14 is not 1%, but 0.1% unless set. I'm not sure if t
  3. I ran into this too and had to chmod them to 777 them. BUT I think the problem might also be related to owner and groups to use anything other then 777. I'm not a Linux hack, but Larry might chime in with more insight, but I can't remember if I changed them www-data:www-data or something like that and less then 777 for the access. I'm just moving stuff to Amazon Web Services and just set a few of the directories to 777 to get things going will experiment with it and if it's anything different then 777 will tell the tail Sandy
  4. Edward - Don't create the sizes on the fly It's brutal for CPU utilization. I have had to fix up a few old Wordpress sites that relied on autosizing the images with timthumb.php. After removing that option to autosize images on the fly cpu's became quite even with the caching that it had. One other area to watch out for on some autosized images is that file size will become larger after re-sizing. I think this was related to how the resizers are set up for compression and how they do their job. Some seem to convert .jpg to .png and back to .jpg to do the work and the file sizes with d
  5. One more .htaccess post - Moving your Yii app out of web root Just got the rest of my .htaccess working for the Yii app I have been working on. The Yii app is in a subdir under the web root. This seems to work well and is similar to some of the above examples, posting as it's always madding dealing with .htaccess and making things work ... This was cobbled from some other .htaccess files I had found. Put this in your webroot's .htaccess not in the local Yii App directory replace subdir with the directory that your yii app is in (with index.php) replace yourdomain with the doma
  6. This was a huge help. Here are a few more things to check, I'm running Ubuntu/Mint 15 on a virtualBox instance. I could not get the simple examples working, .htaccess and the code was as the book has but no-go. Looked at the apache2 enabled modules in /etc/apache2/mods-enabled and saw that their was a symlink set up to rewrite.load so the module was setup for loading. Then took a look at /etc/apache2/sites-enabled directory, it has one entry in my case which is a symlink to the /etc/apache2/sites-available/default file where I found pretty much what Gio said, <Directory
×
×
  • Create New...