Jump to content
Larry Ullman's Book Forums

Recommended Posts

My college is using PHP&MySQL VQP as the text in an online course. We are currently on chapters 4 through 6. The course has little instructor interaction other than reviewing our editing and executing the VQP chapter scripts and building "game" php applications.

 

I've been Googling several sites trying to find step by step "cookbook" instructions on using my localhost phpmyadmin tool on a Windows 7 xampp installation. I've found the Documentation.txt assumes a wider set of experiences than beginning students can bring - especially those without access to a subject matter expert.

 

Here is what I've been able to do so far:

 

1. XAMPP 1.8.0 / PHP 5.4.4 / SQL 5.5.25a - installation for Windows 7 completed successfully

 

2. XAMPP Control Panel v3.0.12 -Apache- and -MySQL- systems started each time

 

3. PHP exercises from chapters 1 through 3 in PHP&MySQL VQP completed successfully

 

4. Signed on mysql line command as 'root' user, created tables and inserted records successfully

 

5. Tried http : // localhost / phpmyadmin - returns error as shown on text page 125 illustration "I" (eye)

 

6. Edited file 'xampp \ phpMyAdmin \ config.inc.php'

 

7. Supplied:

 

- auth_type = 'cookie';

- host = 'localhost'; (note: I found this in config.sample.inc, not in config file)

- password = (root password used in command line login - verbatim, not hash)

- extension = 'mysql';

- allownopassword = false;

 

8. Browsed to http : // localhost / xampp and clicked Tools / phpMyAdmin

 

9. Error message as shown on VQP p. 125

 

Some starting questions:

 

- What else is necessary to use phpMyAdmin other than updating the inc.config file above?

 

- I was not able to find info on phpMyAdmin in the Appendix A pdf - only user setup instructions

 

- Is there a sequence to editing the config file and starting/restarting Apache and/or MySQL?

 

- Should I already be signed in to mysql 'root' before trying to start phpMyAdmin?

 

Thank you for any light you can shed. If there is another text which more completely addresses setting up phpMyAdmin parameters, please let me know.

Link to post
Share on other sites

I'm not sure what's up with all the spaces in your URLs, but using the default XAMPP installation, if you have both Apache and MySQL running, simply go to the following URL:

http://localhost/phpmyadmin/

 

That should definitely open up phpMyAdmin.

If it doesn't, try uninstalling XAMPP, restarting Windows 7, and then reinstalling XAMPP. Then, repeat the instructions above.

 

Again, if that doesn't work, then something is wrong with your XAMPP installation.

Please let us know if you're able to get that far.

Thanks.

  • Upvote 1
Link to post
Share on other sites

Thank you. I apologize for not getting back sooner.

 

The solution was to add "host=localhost", which did not exist in the download config file but did in the sample file. The reason I did not see this change solve my issue at the time was that IE9 continued to display the error from cache instead of reloading the corrected version.

 

Two lessons come out of this:

 

New users need to add the "host=" parameter to the XAMPP phpMyAdmin config file.

 

IE9 (probably all IE and perhaps Firefox, etc.) need to have set options parameter 'new versions of sorted pages' to "every time I visit the webpage".

 

This will (I hope) assure that changes to the config file(s) will be accurately displayed. I can do this without browser speed issues because I've set it on a dedicated laptop used only for web programming. Folks browsing from multi-application machines will probably want to fine tune this setting to keep their browsing speedy.

 

Thanks for your help.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...