Jump to content
Larry Ullman's Book Forums
Sign in to follow this  
bangweb

Install Went Like Clockwork - Files Appear In The Webroot - Getting 500 Internal Server Error

Recommended Posts

Hi,

 

I am following the blog tutorial about getting started. I am on a dedicated server running whm/cpanel.

 

I put the framework directory at /home/testsite/framework/ and the web root is /home/testsite/public_html/

 

Connected via ssh as the user "testsite" (not root) and from the framework directory ran

 

php yiic.php webapp ../public_html

 

Confirmed y and the installation ran successfully.

 

I visually confirmed the file and directories created in /public_html/.

 

When I browse to http://testsite.com/ i get a 500 Internal Server error (and Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.)

 

I also tried to browse to http://testsite.com/index.php unsuccessfully (i verified that that file is there.

 

I have verified that the owner of the files is testsite and the permissions are such normal.

 

The Apache error log shows only:

 

 

[Fri Jan 04 19:38:25 2013] [error] [client 192.168.1.15] File does not exist: /home/testsite/public_html/404.shtml

[Fri Jan 04 19:38:25 2013] [error] [client 192.168.1.15] File does not exist: /home/testsite/public_html/favicon.ico

[Fri Jan 04 19:38:25 2013] [error] [client 192.168.1.15] File does not exist: /home/testsite/public_html/500.shtml

[Fri Jan 04 19:38:25 2013] [error] [client 192.168.1.15] SoftException in Application.cpp:256: File "/home/testsite/public_html/index.php" is writeable by group

 

I have also restarted httpd.

 

Does anyone have any suggestions of what to check next?

 

Regards,

Steve

Share this post


Link to post
Share on other sites

Hmmm...how about just creating an index.html file, putting it in the Web directory, and testing it in your browser?

Share this post


Link to post
Share on other sites

First of all - you need to double check your .htaccess as well as all Apache configuration files, especially httpd.conf file.

 

Internal Server Error (code 500) is usually a consequence of misused rewrite rules, so the easy way is to temporary disable mode_rewrite module and check how is site performing without it. If the error is gone - you know where to look around...

Share this post


Link to post
Share on other sites

Thanks to you both for your suggestions.

 

I'm not sure what the issue ended up being. But here are the steps that got it working (although I can't explain why) and hopefully will help someone else with the same issue.

 

I deleted all the files in the web root. Uploaded a basic index.php that echoed hello as per Larry's suggestion and that worked fine.

 

I re-ran "php yiic.php webapp ../public_html" and everything worked.

Just to make sure it wasn't a fluke on the installation this time, I deleted the files in the web root and ran the yiic app again and it installed fine again.

 

This was probably just something wonky on my server. But hopefully this will help someone else down the road.

 

Thank you again,

Steve

Share this post


Link to post
Share on other sites

Unfortunately sometimes we don't know why things didn't work, but it's great that you're working now. Thanks for letting us know.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...