Jump to content
Larry Ullman's Book Forums
Sign in to follow this  
Alex1

PHP for the Web Chapter 12 and 13 Myblog and Mysql help

Recommended Posts

This is sort of long.

 

Chapter 12

I am going through chapter 12 in the Quick Start Guide PHP for the Web and am having an issue creating the myblog database on PHPMyAdmin from Installation and Configuration A. I have created the database in PHPMyAdmin with the database button. This gives me the option to make a table and columns. I am not sure where I am supposed to put the text:

1125577696_Screenshot(109)_LI.thumb.jpg.e9305b21cbfe9b3f28858c5df9e1f8a1.jpg

I am not sure where this is supposed to go on PHPMyAdmin in order to make the database. The book doesn't explain where it is supposed to go.

 

929968456_Screenshot(108).thumb.png.29cad3153a89f5c52c02b8522100904a.png

 

When I try and connect to mysql I get the error:

Quote

 

Warning: mysqli_connect(): (HY000/1045): Access denied for user 'username'@'localhost' (using password: YES)

Could not connect to the database

 

I am guessing that this is because I have not been able to make the database, and that it might go away after I make it.

I am using Mysql Workbench which seems as well as XAMPP. The server status is able to run but it is not able to connect. The user is root

I am also having other errors with the other pages, such as Edit an Entry

Quote

 

Warning: mysqli_connect(): (HY000/1045): Access denied for user 'username'@'localhost' (using password: YES) in C:\xampp\htdocs\PHP\Chapter 12\edit_entry.php on line 13

Warning: mysqli_set_charset() expects parameter 1 to be mysqli, bool given in C:\xampp\htdocs\PHP\Chapter 12\edit_entry.php on line 16

This page has been accessed in error.
Warning: mysqli_close() expects parameter 1 to be mysqli, bool given in C:\xampp\htdocs\PHP\Chapter 12\edit_entry.php on line 72

 

This will probably be fixed after I am able to connect to Mysql.

Chapter 13

The page titled My Site of Quotes does not work because I am getting a lot of errors.

 

1260990203_Screenshot(111).thumb.png.3c1e7e498934ad4271925bed85258560.png

 

This might be because I have not gotten Mysql to run yet, and it might be fixed after. The other pages have similar issues.

 

I also wanted to check to make sure that I have the files set up correctly.

Here is what it is supposed to look like:

Image

 

Here are how my files are set up

 

1937064317_Screenshot(112).thumb.png.e8a9d735c22f4bf1e1d83e0489948724.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...