Jump to content
Larry Ullman's Book Forums

Recommended Posts

Hi All,

 

I updated the PHP installed with Mac OSX Mavericks (10.9). The installed version was some flavor of 5.4, I believe. The updated version is 5.5.6.

 

I wanted to turn off output buffering to instruct myself on what happens when it is off and when it is on.

 

I tried to change output buffering like so (these are the grouped directives as given, with the fifth line as my own addition):

 

;  output_buffering
;  Default Value: Off
;  Development Value: 4096
;  Production Value: 4096
   output_buffering = Off

 

I saved the directive, quit the terminal, and restarted Apache (almost a dozen times). The directive remained the same, but my_phpinfo.php will not change. It still says "output_buffering=4096".

 

The my_phpinfo.php page in this version indicates the following path for the loaded configuration file:

 

/usr/local/php5/lib/php.ini

 

It also indicates the following path to a directory that contains additional .ini files:

 

/usr/local/php5/php.d

 

This directory contains the following .ini files:

 

10-extension_dir.ini        50-extension-pdo_pgsql.ini
50-extension-apcu.ini        50-extension-pgsql.ini
50-extension-curl.ini        50-extension-readline.ini
50-extension-gmp.ini        50-extension-redis.ini
50-extension-igbinary.ini    50-extension-solr.ini
50-extension-intl.ini        50-extension-ssh2.ini
50-extension-mcrypt.ini        50-extension-twig.ini
50-extension-memcache.ini    50-extension-uploadprogress.ini
50-extension-memcached.ini    50-extension-xdebug.ini
50-extension-mongo.ini        50-extension-xhprof.ini
50-extension-mssql.ini        50-extension-xsl.ini
50-extension-oauth.ini        99-liip-developer.ini
50-extension-pdo_dblib.ini
 

When, for instance, I changed date.timezone in the main .ini file, my_phpinfo.php didn't update. I had to also change it in "99-liip-developer.ini", in order to overwrite "Zurich" with "America/Los_Angeles".

 

Could it be that output_buffering is also a directive in one of the additional .ini files? I'm not being lazy. I don't mind going through those files one-by-one to see if it's in there so I can change it. But if someone knows beforehand that would help.

 

Also, how can I tell if output_buffering is on, despite what may be indicated in my_phpinfo.php? Or is it that whatever is indicated in my_phpinfo.php is "always accurate", thereby precluding the need to test output_buffering?

 

I appreciate your help.

 

Roland

Share this post


Link to post
Share on other sites

Editing the /usr/local/php5/lib/php.ini file will suffice. The problem is you're editing an earlier line in the script, under the "Quick Reference" section. Later in the script you'll find another output_buffering line which is setting the value to 4096.

 

Also make sure you restart the web server after saving your changes.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...