Jump to content
Larry Ullman's Book Forums

Recommended Posts

I posted this on Apache Friends but thought I'd post here too.

 

I upgraded to Yosemite. I downloaded and installed the most recent version of XAMPP. I changed / updated the root and pma passwords in the config.inc.php file.

I can see all DBs and tables, but cannot access any tables (!! exception = I can access the phpmyadmin tables). I can create new tables in any DB.

Every time I get a #1146 - Table ... doesn't exist error.  

It is exactly the same problem as described here on stack overflow (with no solution):  

http://stackoverflow.com/questions/26438068/xampp-not-working-os-x-yosemite

HELP! Thanks!

Link to post
Share on other sites

If you can see the databases and tables but not access them, it's most likely a permissions error. I'd make the permissions on the old database files match those on the phpMyAdmin tables. You'll need to do this using the Terminal. 

Link to post
Share on other sites

Thank you, Larry.  That's what I think too, but can't figure out how to solve it.  

 

Could you provide a bit more information as to how to do that?  

 

I have set passwords for all users and added the passwords to the config.inc.php file.  

 

Screenprint:  https://drive.google.com/open?id=0B9uvP7GK92uPWmpkV0w4Z1RFdms&authuser=0

 

Can't think of what to try next...

Link to post
Share on other sites

I'm probably missing something obviously stupid, but appear not to have that file structure:  "-bash: cd/usr/local: No such file or directory"  

 

My path on a Mac using XAMPP to get to phpMyAdmin is:  Applications > XAMPP > xamppfiles > phpmyadmin

The mysql path is: Applications > XAMPP > xamppfiles > mysql 

 

If I run the ls -al on this path: Applications > XAMPP > xamppfiles > var > mysql

I get this result: -bash: is: command not found

 

I'm sure I'm missing something very basic; sorry! 

Link to post
Share on other sites

If you're using XAMPP, then it's 

cd /Applications/XAMPP/

not

cd /usr/local

Except I don't know where XAMPP keeps the databases within the directory, so you'll need to hunt around for the "data" directory. You can do this in the Finder.

 

Also, the other command is "ls", not "is". 

Link to post
Share on other sites

Just an update: I was never able to fix the problems.

After a while, MySQL simply stopped working all together.
The only thing that ultimately "fixed" the problem was not only to uninstall and reinstall XAMPP, but I also had to manually blow away all the XAMPP folders and files after uninstalling and before reinstalling.
I would advise anyone upgrading to Yosemite to:
- Save off a copy of each DB
- Save off a copy of all PHP / code files
Then it's just an "easy" matter of copying back the php files and importing the DBs.

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...