Jump to content
Larry Ullman's Book Forums
Sign in to follow this  
martinb

Composer And Strip Bindings Version 2+

Recommended Posts

Your recommending is use 'composer' which I beleive is needed for version 2+ Stripe Bindings.    "In 2015, Stripe updated its PHP library to version 2, which requires PHP 5.3 or greater. It also assumes you’re using Composer (which you really ought to be using)."    

 

Looking at the 'https://getcomposer.org/'website, it seems focused on local environment installation and not a remote server environment.      I only use my computer for writing PHP script and upload by FileZilla to a remote server for website hosting.      Is 'composer' and hence Stripe bindings 2+ applicable?    

 

Thanks,

Share this post


Link to post
Share on other sites

Sure thing! First, to clarify, Composer can be used to install code/software on ANY computer. For a server, you'd just need to run Composer from that server (e.g., after connecting via SSH). If that's not possible, or if you just don't want to, then use Composer to install the Stripe library on your computer and upload the generated "vendor" folder, and its contents, to your server using FileZilla. 

Share this post


Link to post
Share on other sites

Thank you for your good advice.     

 

Checking further, the server (for our website) is using PHP 5.2.17.       So PHP version 2 library can't apply. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...