Jump to content
Larry Ullman's Book Forums
Sign in to follow this  
neophyte

Chapter 9 Creating Cookies P247

Recommended Posts

Hi Larry,

 

I am using IE8. I changed my privacy settings to:

'Override automatic cookie handline' and I marked "Prompt" under both First-party and Third-party Cookies.

 

When I go to any www.'website'.com I get a Privacy Alert message.

 

But when I run Script 9.1 as http://localhost/view_settings.php, it proceeds with no alerts, warnings, or prompts, and goes right to a page showing my choices.

 

I tried substituting your script from the downloads, just to find if it was an error in my script, but I got the same results.

 

(I wanted to try it in FireFox,[version 3.6.17] but I was unable to find the options I needed in the privacy settings tab... )

 

Any suggestions?

 

THANKS

Share this post


Link to post
Share on other sites

I run firefox 5.0 but it should in options > privacy > history > "use custom settings for history" (This may be a drop down box saying either 'remember history', 'never remember history' or 'use custom settings'.

 

Then you can change your cookie preferences ;)

Share this post


Link to post
Share on other sites

I forget whether I explicitly say this in the book or not (I believe I do), but some browsers, and by some I think I just mean IE, won't prompt for cookies when running sites on localhost. This is in a tip, I believe.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...