Jump to content
Larry Ullman's Book Forums

Error: #2002 - The Server Is Not Responding (Or The Local Mysql Server'S Socket Is Not Correctly Configured)

Recommended Posts

I am trying to assign the password to the root user via phpMyAdmin as explained in Appendix A on page 432 - I referred back to page 428 to gain access to use phpMyAdmin.


When I try to open the link in my browswer - I get this error


#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

Connection for controluser as defined in your configuration failed.


I googled the error and someone said to replace the http://localhost/phpMyAdmin with

I did that and it worked. Why?

Link to post
Share on other sites

So then....I followed the instructions after I got logged in and I changed the password and I then went to the config file and changed that and now I can't get in with either url!


It says this:

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.


What did I do wrong and how do I fix it so I can continue with the chapters?

Link to post
Share on other sites

According to the book - the fgetcsv() function breaks the string into parts using the marked separator and returns an array. So the way I see it - fopen has opened my file as one string and teh fgetcsv is separating it out and my while loop is looping through the file until the end. So what have I done wrong again?

Link to post
Share on other sites

I know this is pretty basic - but when I write echo $data

All I get returned You could not be registered due to a system error. I can't even echo things out!


But from your last statement I feel you think I should change my variable

$open = fopen("$data",r');

to something else? I tried $file and I even tried the raw file path and name. I still got the same errors.


I am sorry I am not getting this, but I feel like you are talking to me "encrypted" I just don't understand what you are trying to tell me....

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...