Jump to content
Larry Ullman's Book Forums

Recommended Posts

Hello everyone,

 

My boss has two websites -- one of which they wanted me to clone to replace the other. They are on two different servers.

 

They had me transfer the website files, reconfigure to a new database on a new server, and then make cosmetic changes.

 

However, I am finding that none of the links on the clone (apart from the home page) actually work. For instance, if you click "What's New" this should link to the Who We Are page. The URL it links to is: /who-we-are (without any php extension).

 

There is a .php file on public_html that is titled "who-we-are.php." The absence of an extension in the URL made me think there was an .htaccess file, and there was:

 

[/color][/color][/font][/size]
Options -MultiViews
Options +FollowSymLinks
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
#RewriteRule ^(.*)$ $1.php [L,QSA]

RewriteRule ^search([\/]?)$ index.php?option=collection-products&section=collection&%{QUERY_STRING}  [L,QSA]

RewriteRule ^page\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=pages&url=$1&%{QUERY_STRING}  [L,QSA]

RewriteRule ^product\/([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=product&category=$1&producturl=$2&%{QUERY_STRING}  [L,QSA]

RewriteRule ^products\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=collection-products&section=collection&productcat=$1&%{QUERY_STRING}  [L,QSA]
RewriteRule ^products\/([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=collection-products&section=collection&category=$1&productcat=$2&%{QUERY_STRING}  [L,QSA]
RewriteRule ^products\/([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=collection-products&category=$1&section=collection&subcategory=$2&productcat=$3&%{QUERY_STRING}  [L,QSA]


RewriteRule ^collection\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=collection&section=collection&category=$1&%{QUERY_STRING}  [L,QSA]
RewriteRule ^collection\/([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=collection&section=collection&category=$1&subcategory=$2&%{QUERY_STRING}  [L,QSA]

#RewriteRule ^detail\/([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=cat_page_more&section=$1&category=$2&%{QUERY_STRING}  [L,QSA]

#RewriteRule ^philanthropy([\/]?)$ index.php?option=our-work&section=philanthropy&&%{QUERY_STRING}  [L,QSA]
RewriteRule ^philanthropy\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=cat_pages&section=philanthropy&category=$1&%{QUERY_STRING}  [L,QSA]
RewriteRule ^philanthropy\/([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=cat_page_detail&section=philanthropy&category=$1&pageurl=$2&%{QUERY_STRING}  [L,QSA]

RewriteRule ^our-work\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=cat_pages&section=our-work&category=$1&%{QUERY_STRING}  [L,QSA]
RewriteRule ^our-work\/([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=cat_page_detail&section=our-work&category=$1&pageurl=$2&%{QUERY_STRING}  [L,QSA]

RewriteRule ^([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=cat_page_detail&section=$1&pageurl=$2&%{QUERY_STRING}  [L,QSA]

RewriteRule ^our-services([\/]?)$ index.php?option=cat_pages&section=our-services&%{QUERY_STRING}  [L,QSA]
#RewriteRule ^philanthropy([\/]?)$ index.php?option=cat_pages&section=philanthropy&%{QUERY_STRING}  [L,QSA]
RewriteRule ^conceptual-gift-design([\/]?)$ index.php?option=cat_pages&section=conceptual-gift-design&%{QUERY_STRING}  [L,QSA]

#RewriteRule ^our-services\/([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=cat_page_detail&section=our-services&pageurl=$1&%{QUERY_STRING}  [L,QSA]


#RewriteRule ^our-work([\/]?)$ index.php?option=collection&section=our-work&%{QUERY_STRING}  [L,QSA]



RewriteRule ^([a-zA-Z0-9_-]+)([\/]?)$ index.php?option=$1&%{QUERY_STRING}  [L,QSA]

 

It references a symlink. On the original website, there are two symlinks in the root/ folder (not public_html) that are titled: www -> public_html; and then another called, access_logs -> ../domlogs/artmorp1.

 

I assume I need to add the symlinks to the new server for the new site, but can anyone help me understand what is actually going on in this situation?

 

It would help if you could point out what the problem with the clone, and give me suggestions as to how to fix it.

 

Many thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...