Jump to content
Larry Ullman's Book Forums

milo99

Members
  • Content Count

    12
  • Joined

  • Last visited

Community Reputation

0 Neutral

About milo99

  • Rank
    Newbie
  1. Thanks for your replies everyone. I did manage to get it working. I have decided to step back from the Yii side for a little while as I work my way through Larry's PHP book first. I will be back at it soon and am sure I will have a million questions for you when I do :-)
  2. Hmm still no luck... this is what it says on the yii site: % cd WebRoot on my computer I think that is... % cd Library/WebServer/Documents but it says '-bash: fg: %: no such job' when I hit enter % php YiiRoot/framework/yiic.php webapp testdrive on my computer I think this is... % php Applications/MAMP/htdocs/yii/framework/yiic.php webapptestdrive but it says '-bash: fg: %: no such job' when I hit enter I have tried this in so many variations now that I think I am going to go insane. Nothing works.
  3. Hi Larry, I bought your book PHP and MYSQL for dynamic websites and have found it very easy to follow. I am completely new to PHP so that was important. I am actually a graphic designer but my company is working on a huge project that is built on the yii framework so they want us ALL to learn it. I am having a problem right from the get go with the terminal command. Nothing I type in seems to work. I am having trouble even understanding why I need to use terminal. I am not sure if this helps but I have installed MAMP on my Macbook Pro. I ran this after I installed yii and it passed: http:
  4. So yes turning on the display errors has already worked for me as when I first ran this script I had an error on line 73 which I easily found. I also had another issue and I posted a big long speel about it here but I did figure it out I had $REQUEST instead of $_REQUEST. I am actually finding this PHP fun to work on now.
  5. Thanks again Edward my host has done this. Now I just need to make another error to test it out ;-)
  6. Again here are the urls (I know I could just cut and paste the code from the book but I am trying to type it out myself so I can spot the problems later on but again I just don't see anything wrong) http://canucklist.co...book/form2.html http://canucklist.co...andle_form2.php
  7. hmm here is another one. How do you paste her with the colors Edward? When I paste my code here it is just black. Anyway can you see a problem here? <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en"lang="en"> <head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> <title> Feedback Form</title> </head> <body> <?php $name = $_REQUEST['name']; $email = $_REQUEST['email']; $c
  8. Ah yes that worked nicely thanks. Yikes one missing " can throw a wrench in your whole day can't it. Thanks again
  9. Hi Margaux thanks I am actually using Text Wrangler as well I just copied the code above from text edit though sorry.
  10. No I am affraid that is not the problem. This is making me a little nuts because it is so simple. These are the actual pages... http://canucklist.com/php/php-book/handle_form.php http://canucklist.com/php/php-book/form.html
  11. Sorry I know this is a super simple script but I just can't see the error. I get Server Error HTTP Error 500. I have tried removing bits, tweaking, re-writing and I cannot believe this won't work. It is not my server as I have several hundred php scripts running on it without issue... HTML... <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en"lang="en"> <head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
×
×
  • Create New...