Jump to content
Larry Ullman's Book Forums

Problem With Crud Employee Department - Case


Recommended Posts

Larry

 

I am enjoying your very clear instructions but I have run into problems with GII

 

I am running wamp, all checks out fine, I copy and paste your sql into MYSQL workbench 5.2 to create the two tables,

 

These are created in a database called testdrive

 

I used your config guide to ensure the Mysql connection string is correct etc

 

but in CRUD I get

Class 'employee' does not exist or has syntax error.

 

and even using proper case as per your example

 

 

Model Class *

Class 'Employee' does not exist or has syntax error.

Controller ID *

Base Controller Class *

Controller

Code Template *

default (C:\wamp\www\yiiroot2\framework\gii\generators\crud\templates\default)

 

My dev environment is Windows 7, Firefox Browser

 

The interesting thing is that I can see in MYSQL Workbench the two tables BUT it doesnt matter what I do I cannot enforce the capitals you use on the tables so my tables are all lowercase and I suspect the columns too

 

I have googled for an explanation on how to fix capialisation and the only thing I have picked up is a setting set-variable=lower_case_table_names=0 to 2 and I cannot find this in my.ini at all so included it and have tried all values 0-2 when I use the sql rename table employee to emp and then rename table emp to Employee

 

nothing changes the case.....

 

any advice would be welcome

 

george

Link to post
Share on other sites

can anyone help me with the application log, to see what it was trying to do

21:09:25.844276 trace system.CModule

Loading "log" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.851540 trace system.CModule

Loading "request" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.855421 trace system.CModule

Loading "urlManager" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.859976 trace system.base.CModule

Loading "gii" module

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.879512 trace system.CModule

Loading "user" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.882555 trace system.CModule

Loading "session" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.889846 trace system.CModule

Loading "db" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.892019 trace system.db.CDbConnection

Opening DB connection

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.904625 trace system.CModule

Loading "clientScript" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.907804 trace system.CModule

Loading "widgetFactory" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.931981 trace system.CModule

Loading "assetManager" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13) 21:09:25.936292 trace system.CModule

Loading "coreMessages" application component

in C:\wamp\www\yiiroot2\testdrive\index.php (13)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...