Jump to content
Larry Ullman's Book Forums
dmx1

connection issues to checkout.php

Recommended Posts

Hi Larry,

 

I am trying to connect to the checkout.php page, by clicking on the 'checkout' button in the 'cart.php' page, but I get the following error:

 

'An error occurred during a connection to localhost:8888. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.'

 

I have tried using firefox and safari, and still run into the same error.

 

Safari says it can't open the page because it can't establish a secure connection to the server "localhost".

 

Qu: Do you have any idea what the problem might be and the steps I would take in order to solve the above issue please.

 

Thanks

 

 

Share this post


Link to post
Share on other sites

It's probably either a problem with your certificate or your server configuration. What operating system and web server are you running and how did you install and configure the certificate?

Share this post


Link to post
Share on other sites

Larry, I told you I'm a newbie!!  Lol

 

I haven't installed or configured any certificates.

 

How would I go about doing that please?

Share this post


Link to post
Share on other sites

Ah! Then if you haven't acquired a certificate, your HTTPS links won't work. Change them to HTTP. I wouldn't worry about a certificate for now--and certainly don't purchase one yet. 

Share this post


Link to post
Share on other sites

Larry,

I did what you suggested and removed all of the https links and changed them to http, but I am still getting the same error. 

 

Everytime I click on the 'checkout' link in the cart page, I receive an error.

 

My url has the following code:

 

https://localhost:8888/checkout.php?session=378f49d69df81eeb898f6b6a42fa96d5

I also then get the following error:

"Secure Connection Failed

An error occurred during a connection to localhost:8888. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG"

 

So even though I changed all of the https and replaced it with http, I am still getting the same error. I have noticed that the url begins with https and not http, even though I have changed everything to http in the 'checkout', 'billing' and 'final', php and html pages.

 

I have also removed the code from the .htaccess page that enforces SSL on those pages, and still no luck!

 

Qu 1: Why does the url keep on starting with https and not http even though I have changed everything to http?

 

Qu 2: Is there something I am missing, because I can't seem to find out the problem.

 

regards

 

 

 

 

Share this post


Link to post
Share on other sites

So the problem is that you're still viewing an HTTPS page when you don't have HTTPS enabled. I assume it's because of the .htaccess. Did you restart the web server after making the change? 

Share this post


Link to post
Share on other sites

Hi Larry,

It seems it might have been a cache problem. I deleted the cache for my firefox browser.

When I click the link in the 'cart' page to go to the 'checkout' page, I get an error saying:

'Cannot change session id when session is active Array'

It is referring to the checkout.php page, and the line that is giving me the error is:

// Use the existing user ID:
        session_id($uid);

 

So I think by emptying the cache, I somehow deleted the cookies etc.

 

Qu: Do you know how i would solve the above problem?

 

regards

 

Share this post


Link to post
Share on other sites

Hi Larry,

 

I managed to solve the problem. The problem is when I integrate your login form with the ecommerce site, there is a conflict of code.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...